summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 16:42:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 17:12:44 +0100
commit04761fcc1ac1d6f08a0b63b0a5322de1d0c8ebce (patch)
tree163d1c791b43ab9c66d9d9e3e341aa68943ca16e /gnu
parent9900eb1cbb4f50cd39f3ca00e98621fc388a3a0e (diff)
downloadguix-04761fcc1ac1d6f08a0b63b0a5322de1d0c8ebce.tar.gz
gnu: xpdf: Update to 4.02.
* gnu/packages/pdf.scm (xpdf): Update to 4.02.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 173e39a12b..34a3fba042 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -272,13 +272,14 @@ reading and editing of existing PDF files.")
 (define-public xpdf
   (package
    (name "xpdf")
-   (version "3.04")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
-                                version ".tar.gz"))
-            (sha256 (base32
-                     "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
+   (version "4.02")
+   (source
+    (origin
+      (method url-fetch)
+      (uri (string-append "https://xpdfreader-dl.s3.amazonaws.com/xpdf-"
+                          version "4.02.tar.gz"))
+      (sha256
+       (base32 "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
    (build-system gnu-build-system)
    (inputs `(("freetype" ,freetype)
              ("gs-fonts" ,gs-fonts)
@@ -292,8 +293,8 @@ reading and editing of existing PDF files.")
              ("libpng" ,libpng)
              ("zlib" ,zlib)))
    (arguments
-    `(#:tests? #f ; there is no check target
-      #:parallel-build? #f ; build fails randomly on 8-way machines
+    `(#:tests? #f                     ; there is no check target
+      #:parallel-build? #f            ; build fails randomly on 8-way machines
       #:configure-flags
         (list (string-append "--with-freetype2-includes="
                              (assoc-ref %build-inputs "freetype")
@@ -315,7 +316,7 @@ reading and editing of existing PDF files.")
    (synopsis "Viewer for PDF files based on the Motif toolkit")
    (description
     "Xpdf is a viewer for Portable Document Format (PDF) files.")
-   (license license:gpl3) ; or gpl2, but not gpl2+
+   (license license:gpl3)             ; or gpl2, but not gpl2+
    (home-page "https://www.xpdfreader.com/")))
 
 (define-public zathura-cb