summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-02 22:22:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-02 22:23:18 +0100
commit07a2f34d5c8342b88530f8cb968090eccd0da91c (patch)
tree9f787d29b8842575f9d787422f72f45e22f34a1e /gnu
parent5f4565b18fa0bdb0388265c9e97e284826327c3a (diff)
downloadguix-07a2f34d5c8342b88530f8cb968090eccd0da91c.tar.gz
gnu: Add r-statnet-common.
* gnu/packages/cran.scm (r-statnet-common): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 211d292397..e06eb60e94 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2245,3 +2245,23 @@ published results; and a routine for graphical display.")
 @code{network} class can represent a range of relational data types, and
 supports arbitrary vertex/edge/graph attributes.")
     (license license:gpl2+)))
+
+(define-public r-statnet-common
+  (package
+    (name "r-statnet-common")
+    (version "4.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "statnet.common" version))
+        (sha256
+          (base32
+            "0yw6l5b4qv0jqlg4zyczas7m12a5pyqghs6ydxy2f6v6vxkijvi0"))))
+    (properties
+      `((upstream-name . "statnet.common")))
+    (build-system r-build-system)
+    (home-page "http://www.statnet.org")
+    (synopsis "R scripts and utilities used by the Statnet software")
+    (description "This package provides non-statistical utilities used by the
+software developed by the Statnet Project.")
+    (license license:gpl3)))