summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-28 17:57:16 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-28 17:57:37 +0100
commit07af3e5efee742b9b67a19a6df3256cd00fb18e0 (patch)
treee41f324aea4b2a8a040dffafae537daf69590191 /gnu
parenta3bf096945b9e429f0fc5e2de4fb537ec5b1a587 (diff)
downloadguix-07af3e5efee742b9b67a19a6df3256cd00fb18e0.tar.gz
gnu: Fix or update a number of 'home-page' fields.
* gnu/packages/fltk.scm (fltk): Fix 'home-page'.
* gnu/packages/fonts.scm (font-bitstream-vera): Likewise, and fix
  license URL.
* gnu/packages/games.scm (gnubg, cmatrix, chess): Fix 'home-page'.
* gnu/packages/kde.scm (attica): Likewise.
* gnu/packages/mail.scm (fetchmail): Likewise.
* gnu/packages/popt.scm (popt): Likewise.
* gnu/packages/python.scm (python-mock): Likewise.
* gnu/packages/stalonetray.scm (stalonetray): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fltk.scm2
-rw-r--r--gnu/packages/fonts.scm6
-rw-r--r--gnu/packages/games.scm6
-rw-r--r--gnu/packages/kde.scm2
-rw-r--r--gnu/packages/mail.scm2
-rw-r--r--gnu/packages/popt.scm4
-rw-r--r--gnu/packages/python.scm2
-rw-r--r--gnu/packages/stalonetray.scm2
8 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/fltk.scm b/gnu/packages/fltk.scm
index 9d228927d2..6aee41d31f 100644
--- a/gnu/packages/fltk.scm
+++ b/gnu/packages/fltk.scm
@@ -50,7 +50,7 @@
           (substitute* "makeinclude.in"
             (("/bin/sh") (which "sh"))))
         %standard-phases)))
-    (home-page "https://www.fltk.org")
+    (home-page "http://www.fltk.org")
     (synopsis "3D C++ GUI library")
     (description "FLTK is a C++ GUI toolkit providing modern GUI functionality
 without the bloat.  It supports 3D graphics via OpenGL and its built-in GLUT
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 74cfc9dbe1..c16ab93242 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Joshua Grant <tadni@riseup.net>
 ;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
@@ -144,13 +144,13 @@ provide serif, sans and monospaced variants.")
     (native-inputs `(("source" ,source)
                      ("tar" ,tar)
                      ("bzip2" ,bzip2)))
-    (home-page "https://www-old.gnome.org/fonts/")
+    (home-page "http://www.gnome.org/fonts/")
     (synopsis "Bitstream Vera sans-serif typeface")
     (description "Vera is a sans-serif typeface from Bitstream, Inc.  This
 package provides the TrueType (TTF) files.")
     (license
      (license:x11-style
-      "https://www-old.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
+      "http://www.gnome.org/fonts/#Final_Bitstream_Vera_Fonts"))))
 
 (define-public font-gnu-freefont-ttf
   (package
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b8696a5379..066e0e6c46 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -88,7 +88,7 @@
               ("libcanberra" ,libcanberra)))
     (native-inputs `(("python-2" ,python-2)
                      ("pkg-config" ,pkg-config)))
-    (home-page "https://gnubg.org")
+    (home-page "http://gnubg.org")
     (synopsis "Backgammon game")
     (description "The GNU backgammon application can be used for playing, analyzing and
 teaching the game.  It has an advanced evaluation engine based on artificial
@@ -283,7 +283,7 @@ a C library, so they can easily be integrated into other programs.")
                                     (string-append "--prefix=" out)))))
                       %standard-phases)))
     (inputs `(("ncurses" ,ncurses)))
-    (home-page "http://wwww.asty.org/cmatrix")
+    (home-page "http://www.asty.org/cmatrix")
     (synopsis "Simulate the display from \"The Matrix\"")
     (description "CMatrix simulates the display from \"The Matrix\" and is
 based on the screensaver from the movie's website.  It works with terminal
@@ -304,7 +304,7 @@ asynchronously and at a user-defined speed.")
         (base32
          "1jckpg1qi1vjr3pqs0dnip3rmn0mgklx63xflrpqiv3cx2qlz8kn"))))
     (build-system gnu-build-system)
-    (home-page "http://wwww.gnu.org/software/chess")
+    (home-page "http://www.gnu.org/software/chess")
     (synopsis "Full chess implementation")
     (description "GNU Chess is a chess engine.  It allows you to compete
 against the computer in a game of chess, either through the default terminal
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index e97ac277b7..52ed93e6a7 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -153,7 +153,7 @@ and import their menus over DBus.")
     (build-system cmake-build-system)
     (inputs
      `(("qt" ,qt-4)))
-    (home-page "https://projects.kde.org/projects/kdesupport/attica")
+    (home-page "https://projects.kde.org/projects/frameworks/attica")
     (synopsis "Qt library for the Open Collaboration Services API")
     (description "Attica is a Qt library that implements the Open
 Collaboration Services API version 1.6.  It grants easy access to the
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6051dabb29..534476f7d1 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -144,7 +144,7 @@ software.")
     (arguments
      `(#:configure-flags (list (string-append "--with-ssl="
                                               (assoc-ref %build-inputs "openssl")))))
-    (home-page "http://fetchmail.berlios.de/")
+    (home-page "http://www.fetchmail.info/")
     (synopsis "Remote-mail retrieval and forwarding utility")
     (description
      "Fetchmail is a full-featured, robust, well-documented remote-mail
diff --git a/gnu/packages/popt.scm b/gnu/packages/popt.scm
index e822b5c795..9ccca5c8b5 100644
--- a/gnu/packages/popt.scm
+++ b/gnu/packages/popt.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,7 +43,7 @@
                    (substitute* "testit.sh"   ; don't expect old libtool names
                      (("lt-test1") "test1")))
                  %standard-phases)))
-    (home-page #f)
+    (home-page "http://rpm5.org/files/popt/")
     (synopsis "Command line option parsing library")
     (description
      "This is the popt(3) command line option parsing library.  While it is
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index adb84fc5b7..162acec639 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -358,7 +358,7 @@ API for locking files.")
          "0kzlsbki6q0awf89rc287f3aj8x431lrajf160a70z0ikhnxsfdq"))))
     (build-system python-build-system)
     (arguments '(#:test-target "check"))
-    (home-page "http://code.google.com/m/mock/")
+    (home-page "http://code.google.com/p/mock/")
     (synopsis "Python mocking and patching library for testing")
     (description
      "Mock is a library for testing in Python.  It allows you to replace parts
diff --git a/gnu/packages/stalonetray.scm b/gnu/packages/stalonetray.scm
index 762ac8c99b..e1604327ab 100644
--- a/gnu/packages/stalonetray.scm
+++ b/gnu/packages/stalonetray.scm
@@ -38,7 +38,7 @@
          "1wp8pnlv34w7xizj1vivnc3fkwqq4qgb9dbrsg15598iw85gi8ll"))))
     (inputs `(("libx11" ,libx11)))
     (build-system gnu-build-system)
-    (home-page "stalonetray")
+    (home-page "http://stalonetray.sourceforge.net")
     (synopsis "Standalone freedesktop.org and KDE systray implementation")
     (description
      "Stalonetray is a stand-alone freedesktop.org and KDE system