summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 20:32:40 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:19:12 +0200
commit0ab9eba78e37ee83f5e1e40a5c40495c5330a3d8 (patch)
tree8c124ef1a794abcca469afb3f9bbdff83f308dec /gnu
parent5bebb1e81f97001b2346ea309c969c972f109a94 (diff)
downloadguix-0ab9eba78e37ee83f5e1e40a5c40495c5330a3d8.tar.gz
gnu: Add java-qdox-2-M9.
* gnu/packages/java.scm (java-qdox-2-M9): New variable.
(java-qdox): Install from pom file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index dd7bb8cde9..49cfb0a8a5 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3548,7 +3548,28 @@ documentation tools.")
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "qdox.jar"
-       #:tests? #f)); no tests
+       #:tests? #f; no tests
+       #:modules
+       ((guix build ant-build-system)
+        (guix build java-utils)
+        (guix build utils)
+        (sxml simple))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'create-pom
+           (lambda _
+             (with-output-to-file "pom.xml"
+               (lambda _
+                 (sxml->xml
+                   `((project
+                       (modelVersion "4.0.0")
+                       (name "QDox")
+                       (groupId "com.thoughtworks.qdox")
+                       (artifactId "qdox")
+                       (version ,,version))))))
+             #t))
+         (replace 'install
+           (install-from-pom "pom.xml")))))
     (home-page "https://github.com/codehaus/qdox")
     (synopsis "Parse definitions from Java source files")
     (description "QDox is a high speed, small footprint parser for extracting
@@ -3557,6 +3578,23 @@ class/interface/method definitions from source files complete with JavaDoc
 documentation tools.")
     (license license:asl2.0)))
 
+(define-public java-qdox-2-M9
+  (package
+    (inherit java-qdox)
+    (version "2.0-M9"); required by plexus-java
+    (source (origin
+              (method url-fetch)
+              ;; 2.0-M4, -M5 at https://github.com/paul-hammant/qdox
+              ;; Older releases at https://github.com/codehaus/qdox/
+              ;; Note: The release at maven is pre-generated. The release at
+              ;; github requires jflex.
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "com/thoughtworks/qdox/qdox/" version
+                                  "/qdox-" version "-sources.jar"))
+              (sha256
+               (base32
+                "1s2jnmx2dkwnaha12lcj26aynywgwa8sslc47z82wx8xai13y4fg"))))))
+
 (define-public java-jarjar
   (package
     (name "java-jarjar")