summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-20 22:31:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-20 22:38:17 +0200
commit0afd0660c21ba1683c78d8626917e8aad79b6e99 (patch)
treeb4194205d35a8453e7202d34611170569b8cf49b /gnu
parent52305b0ab3f7f1cea5e0977cddea5b929e8260c1 (diff)
downloadguix-0afd0660c21ba1683c78d8626917e8aad79b6e99.tar.gz
gnu: python-pyhamcrest: Use 'git-fetch'.
* gnu/packages/check.scm (python-pyhamcrest)[source]: Use 'git-fetch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7a546b17ce..28d3a46857 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2066,17 +2066,15 @@ retried.")
     (name "python-pyhamcrest")
     (version "1.9.0")
     (source (origin
-              (method url-fetch)
-              (uri
-               (string-append
-                "https://github.com/hamcrest/PyHamcrest/archive/V"
-                version
-                ".tar.gz"))
-              (file-name
-               (string-append name "-" version ".tar.gz"))
+              ;; Tests not distributed from pypi release.
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/hamcrest/PyHamcrest")
+                     (commit (string-append "V" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1lqjajhwf7x7igvvnj5p1cm31y9njy07qby94w18kl6zwbdjqrwy"))))
+                "01qnzj9qnzz0y78qa3ing24ssvszb0adw59xc4qqmdn5wryy606b"))))
     (native-inputs                      ; All native inputs are for tests
      `(("python-pytest-cov" ,python-pytest-cov)
        ("python-mock" ,python-mock)