summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-11-16 10:41:04 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-16 10:43:40 +0100
commit0b4dbb401cd94cd04eab3a25f80cbb3fcd3d1daf (patch)
tree36514449ee34ce653f4983890a98e0571e9a0c0d /gnu
parentafc438231623fceb4ec8f3aa2f8c4e8f99a3ec22 (diff)
downloadguix-0b4dbb401cd94cd04eab3a25f80cbb3fcd3d1daf.tar.gz
gnu: syslinux: Add explicit dependency on mtools.
Suggested by Adam Van Ymeren <adam@vany.ca>
at <https://bugs.gnu.org/28974>.

* gnu/packages/bootloaders.scm (syslinux)[inputs]: Add MTOOLS.
[ARGUMENTS]: In 'patch-files' phase, patch references to 'mcopy' and
'mattrib'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index f988dbc678..20f38b2d0d 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -237,7 +237,8 @@ menu to select one of the installed operating systems.")
          ("perl" ,perl)
          ("python-2" ,python-2)))
       (inputs
-       `(("libuuid" ,util-linux)))
+       `(("libuuid" ,util-linux)
+         ("mtools" ,mtools)))
       (arguments
        `(#:parallel-build? #f
          #:make-flags
@@ -252,11 +253,17 @@ menu to select one of the installed operating systems.")
          #:phases
          (modify-phases %standard-phases
            (add-after 'unpack 'patch-files
-             (lambda _
+             (lambda* (#:key inputs #:allow-other-keys)
                (substitute* (find-files "." "Makefile.*|ppmtolss16")
                  (("/bin/pwd") (which "pwd"))
                  (("/bin/echo") (which "echo"))
                  (("/usr/bin/perl") (which "perl")))
+               (let ((mtools (assoc-ref inputs "mtools")))
+                 (substitute* (find-files "." "\\.c$")
+                   (("mcopy")
+                    (string-append mtools "/bin/mcopy"))
+                   (("mattrib")
+                    (string-append mtools "/bin/mattrib"))))
                #t))
            (delete 'configure)
            (add-before 'build 'set-permissions