summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-23 22:15:19 -0400
committerMark H Weaver <mhw@netris.org>2015-07-06 21:36:33 -0400
commit0ba652b2f58bcc9fee16228721c77d3676b17302 (patch)
tree8b746f13d14856be8e0b4000c60f3344f2a3a444 /gnu
parent723e886656927f1290596407f2847bee254260d0 (diff)
downloadguix-0ba652b2f58bcc9fee16228721c77d3676b17302.tar.gz
gnu: gst-plugins-good: Disable rtprtx tests that frequently fail.
* gnu/packages/gstreamer.scm (arguments): Add 'disable-failing-rtprtx-tests'
  phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 18329097b0..0f3a0fbdf0 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -222,6 +222,19 @@ for the GStreamer multimedia library.")
      `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after
+          'unpack 'disable-failing-rtprtx-tests
+          (lambda _
+            ;; Disable rtprtx tests that frequently fail.
+            ;; XXX FIXME: Try removing this for version > 1.4.5.
+            (substitute* "tests/check/elements/rtprtx.c"
+              (("tcase_add_test \\(tc_chain,\
+ (test_rtxsender_max_size_packets|test_rtxreceive_data_reconstruction)\\);" all)
+               (string-append "/* " all " */")))
+            #t)))))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis
      "Plugins for the GStreamer multimedia library")