summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-27 22:26:34 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-27 20:14:05 +0100
commit0f4c320c2c831aa1ce38fc908c86a8dc79316811 (patch)
tree8e7981a09eb48243fdb515b137d9a8c9078d5588 /gnu
parent00fad32a2c0c28150901505f7d77272cc44fce84 (diff)
downloadguix-0f4c320c2c831aa1ce38fc908c86a8dc79316811.tar.gz
gnu: kscreenlocker: Use qt-build-system.
* gnu/packages/kde-plasma.scm (kscreeenlocker)[buoild-system]: Change to
  qt-build-system. [arguments]{phases}<check> Remove unsued code; Actually
  disable running the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-plasma.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index d0d1a558b8..c53f6b29c7 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -70,9 +70,10 @@ manager which re-parents a Client window to a window decoration frame.")
               (sha256
                (base32
                 "1fd5sqaqx9kj3kr0bgxpllhcm5arf8bc9pkpd9yk9c8xjy0j0fxi"))))
-    (build-system cmake-build-system)
+    (build-system qt-build-system)
     (arguments
-     `(#:phases
+     `(#:tests? #f ;; TODO: make tests pass
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'check-setup
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -83,13 +84,15 @@ manager which re-parents a Client window to a window decoration frame.")
          (delete 'check)
          ;; Tests use the installed library and require a DBus session.
          (add-after 'install 'check
-           (lambda _
-             (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
-             (invoke "dbus-launch" "ctest" "."))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (if tests?
+                 (begin
+                   (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+                   (invoke "dbus-launch" "ctest" ".")))
+             #t)))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)
-
        ;; For tests.
        ("dbus" ,dbus)
        ("xorg-server" ,xorg-server-for-tests)))