summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHamzeh Nasajpour <h.nasajpour@pantherx.org>2020-09-06 00:30:02 +0430
committerEfraim Flashner <efraim@flashner.co.il>2020-09-06 09:16:11 +0300
commit10ba62ec63f80044c8652a9869f13585f2014ebe (patch)
tree9aab3c9fed8f60a7f4d429229666ac628cf904ed /gnu
parent90a5b6a33d40c6e38155acb48857b6c22b9170a4 (diff)
downloadguix-10ba62ec63f80044c8652a9869f13585f2014ebe.tar.gz
gnu: lxqt-panel: Patch xkeyboard-config location.
* gnu/packages/lxqt.scm (lxqt-panel)[inputs]: Add xkeyboard-config.
[arguments]: Add custom phase to patch the path to xkeyboard-config in
kbindicator for reading the keyboard layouts.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 21587609ce..af452a9903 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -591,7 +591,8 @@ of other programs.")
        ("qtsvg" ,qtsvg)
        ("qtx11extras" ,qtx11extras)
        ("solid" ,solid)
-       ("xcb-util" ,xcb-util)))
+       ("xcb-util" ,xcb-util)
+       ("xkeyboard-config" ,xkeyboard-config)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("lxqt-build-tools" ,lxqt-build-tools)
@@ -619,7 +620,15 @@ of other programs.")
                (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
                 (string-append (assoc-ref outputs "out")
                                "/share/lxqt/translations")))
-             #t)))))
+             #t))
+         (add-after 'unpack 'set-xkeyboard-config-file-path
+                (lambda* (#:key inputs #:allow-other-keys)
+                  ;; Set the path to xkeyboard-config.
+                  (let ((xkb (assoc-ref inputs "xkeyboard-config")))
+                    (substitute* "plugin-kbindicator/src/x11/kbdlayout.cpp"
+                      (("/usr/share/X11/xkb/rules/evdev.xml")
+                       (string-append xkb "/share/X11/xkb/rules/evdev.xml")))
+                  #t))))))
     (home-page "https://lxqt.github.io")
     (synopsis "The LXQt desktop panel")
     (description "lxqt-panel represents the taskbar of LXQt.")