summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-01-07 00:38:50 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-07 00:49:58 +0100
commit11d9077be1097bb6e1cc4f7c960419e8658f2de5 (patch)
tree7002646fa5a26f44f5f301ab6a8974ecd053078d /gnu
parent5527368bccb8cb7bc255bfb4e4dbf7eaa607e8e9 (diff)
downloadguix-11d9077be1097bb6e1cc4f7c960419e8658f2de5.tar.gz
gnu: Add emacs-ebdb-i18n-chn.
* gnu/packages/emacs-xyz.scm (emacs-ebdb-i18n-chn): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a3e1832242..5718541971 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30125,6 +30125,28 @@ a re-write of the Insidious Big Brother Database (BBDB) using Emacs
 Lisp's (relatively new) EIEIO object oriented libraries.")
     (license license:gpl3+)))
 
+(define-public emacs-ebdb-i18n-chn
+  (package
+    (name "emacs-ebdb-i18n-chn")
+    (version "1.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/"
+                           "ebdb-i18n-chn-" version ".tar"))
+       (sha256
+        (base32 "06ii9xi2y157vfbhx75mn80ash22d1xgcyp9kzz1s0lkxwlv74zj"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-ebdb emacs-pyim))
+    (home-page "https://elpa.gnu.org/packages/ebdb-i18n-chn.html")
+    (synopsis "China-specific internationalization support for EBDB")
+    (description
+     "EBDB-i18n-Chn makes EBDB nicer to use with China-based contacts, both
+for handling Chinese characters, and for formatting of phones and addresses.
+Be aware that using this library will incur a non-neglible slowdown at load
+time.  It shouldn't have any real impact on search and completion times.")
+    (license license:gpl3+)))
+
 (define-public emacs-refactor
   (package
     (name "emacs-refactor")