summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-10-31 18:57:30 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-10-31 18:57:30 -0400
commit12d39eb5145e42669748f172f9433ea8e6ead020 (patch)
treeaeb74cf83761d94d82b34a43b20c5da1a4be7784 /gnu
parentd8805b95f5ab563f0b8baf320f1200ca51667793 (diff)
downloadguix-12d39eb5145e42669748f172f9433ea8e6ead020.tar.gz
gnu: ruby: Update to 2.1.4.
* gnu/packages/ruby.scm: Update.  Remove the now redundant readline patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm43
1 files changed, 18 insertions, 25 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a33dabaebd..5cdd722737 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -36,44 +36,37 @@
 (define-public ruby
   (package
     (name "ruby")
-    (version "2.1.3")
+    (version "2.1.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
                            (version-major+minor version)
-                           "/ruby-" version ".tar.bz2"))
+                           "/ruby-" version ".tar.xz"))
        (sha256
         (base32
-         "1mkndw0by11n6lyvq7dzly702yyqg5x0fcvfqrn9y4p49bw75kin"))))
+         "1ksgx1rn4wp80290399q6d26zpbx0nb3sxh45wl4wr58raxmrk71"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
        #:parallel-tests? #f
        #:phases
-       (alist-cons-after
-        ;; Minor patch:
-        ;; https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/45225/diff/
-        'unpack 'patch-readline
+       (alist-cons-before
+        'configure 'replace-bin-sh
         (lambda _
-          (substitute* '("ext/readline/readline.c")
-            (("Function ") "rl_hook_func_t ")))
-        (alist-cons-before
-         'configure 'replace-bin-sh
-         (lambda _
-           (substitute* '("Makefile.in"
-                          "ext/pty/pty.c"
-                          "io.c"
-                          "lib/mkmf.rb"
-                          "process.c"
-                          "test/rubygems/test_gem_ext_configure_builder.rb"
-                          "test/rdoc/test_rdoc_parser.rb"
-                          "test/ruby/test_rubyoptions.rb"
-                          "test/ruby/test_process.rb"
-                          "test/ruby/test_system.rb"
-                          "tool/rbinstall.rb")
-             (("/bin/sh") (which "sh"))))
-         %standard-phases))))
+          (substitute* '("Makefile.in"
+                         "ext/pty/pty.c"
+                         "io.c"
+                         "lib/mkmf.rb"
+                         "process.c"
+                         "test/rubygems/test_gem_ext_configure_builder.rb"
+                         "test/rdoc/test_rdoc_parser.rb"
+                         "test/ruby/test_rubyoptions.rb"
+                         "test/ruby/test_process.rb"
+                         "test/ruby/test_system.rb"
+                         "tool/rbinstall.rb")
+            (("/bin/sh") (which "sh"))))
+        %standard-phases)))
     (inputs
      `(("readline" ,readline)
        ("openssl" ,openssl)