summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-29 19:00:31 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:17 +0100
commit169237aae530bff4c7322dec863d2189879a0af6 (patch)
tree970cf60c6f6e301ef65eea106eea9496fd4b1d46 /gnu
parent7996bd3955bc3ce799bf41a3195f6188b44b7234 (diff)
downloadguix-169237aae530bff4c7322dec863d2189879a0af6.tar.gz
gnu: purescript: Drop Haskell libraries and documentation.
* gnu/packages/purescript.scm (purescript)[arguments]: Add
'remove-libraries phase and disable #:haddock?.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/purescript.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index d968a6f0e6..0a5eccc459 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -99,13 +99,17 @@
      `(;; Tests require npm
        #:tests? #f
        #:configure-flags '("--flags=release")
+       #:haddock? #f
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'update-constraints
            (lambda _
              (substitute* "purescript.cabal"
                (("\\b(language-javascript|process)\\s+[^,]+" all dep)
-                dep)))))))
+                dep))))
+         (add-after 'register 'remove-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))))
     (home-page "https://www.purescript.org/")
     (synopsis "Haskell inspired programming language compiling to JavaScript")
     (description