summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-07-24 20:22:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 23:05:39 +0200
commit1adb9cbc5e9e4c458bbf3b3bb89fcd36278d34e2 (patch)
tree18762888d4e4bf155eec90b383a97e9dcb9dd7dc /gnu
parent1502751b3220feda44e34c07c617086538ac1296 (diff)
downloadguix-1adb9cbc5e9e4c458bbf3b3bb89fcd36278d34e2.tar.gz
gnu: Add r-mixomics.
* gnu/packages/bioconductor.scm (r-mixomics): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ad48ccaebe..f63bfa4a1f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4932,3 +4932,45 @@ change point detection.")
      "FlowSOM offers visualization options for cytometry data, by using
 self-organizing map clustering and minimal spanning trees.")
     (license license:gpl2+)))
+
+(define-public r-mixomics
+  (package
+    (name "r-mixomics")
+    (version "6.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "mixOmics" version))
+       (sha256
+        (base32
+         "1f08jx35amn3sfcmqb96mjxxsm6dnpzhff625z758x1992wj4zsk"))))
+    (properties `((upstream-name . "mixOmics")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-corpcor" ,r-corpcor)
+       ("r-dplyr" ,r-dplyr)
+       ("r-ellipse" ,r-ellipse)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-gridextra" ,r-gridextra)
+       ("r-igraph" ,r-igraph)
+       ("r-lattice" ,r-lattice)
+       ("r-mass" ,r-mass)
+       ("r-matrixstats" ,r-matrixstats)
+       ("r-rarpack" ,r-rarpack)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-reshape2" ,r-reshape2)
+       ("r-tidyr" ,r-tidyr)))
+    (home-page "http://www.mixOmics.org")
+    (synopsis "Multivariate methods for exploration of biological datasets")
+    (description
+     "mixOmics offers a wide range of multivariate methods for the exploration
+and integration of biological datasets with a particular focus on variable
+selection.  The package proposes several sparse multivariate models we have
+developed to identify the key variables that are highly correlated, and/or
+explain the biological outcome of interest.  The data that can be analysed
+with mixOmics may come from high throughput sequencing technologies, such as
+omics data (transcriptomics, metabolomics, proteomics, metagenomics etc) but
+also beyond the realm of omics (e.g.  spectral imaging).  The methods
+implemented in mixOmics can also handle missing values without having to
+delete entire rows with missing data.")
+    (license license:gpl2+)))