summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-06-19 08:39:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-06-19 08:41:54 +0300
commit20b7b75c3225a567637f5fe660fd4a80c59e58be (patch)
tree42bf642689c4b3d7fb287f7c290337068e32b32b /gnu
parent83acf3ead40702ed52307fa19db9c847a5c947e8 (diff)
downloadguix-20b7b75c3225a567637f5fe660fd4a80c59e58be.tar.gz
gnu: gnome-planner: Fix building on aarch64.
* gnu/packages/gnome.scm (gnome-planner)[arguments]: Add configure-flag
to set build-target when building on aarch64.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 43b7e0ac47..34bd33813d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6291,7 +6291,11 @@ text views, and buttons to choose the language.")
      ;; Disable the Python bindings because the Planner program functions
      ;; without them, and (as of 2017-06-13) we have not packaged all of
      ;; packages that are necessary for building the Python bindings.
-     `(#:configure-flags (list "--disable-python")))
+     `(#:configure-flags
+       (list "--disable-python"
+             ,@(if (string=? "aarch64-linux" (%current-system))
+                   '("--build=aarch64-unknown-linux-gnu")
+                   '()))))
     (inputs
      `(("libgnomecanvas" ,libgnomecanvas)
        ("libgnomeui" ,libgnomeui)