summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-24 22:00:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-25 13:03:12 +0300
commit22487dfc227613a5c769435e3448d6b791dc9bf3 (patch)
treec698214e3eb5f0f3b0bbf92bfa47abfe4f9a73ce /gnu
parente77383e16fe4244a82b5e988e6edcfb52bf8965c (diff)
downloadguix-22487dfc227613a5c769435e3448d6b791dc9bf3.tar.gz
gnu: go-gopkg-in-check-v1: Skip tests with gccgo.
* gnu/packages/golang.scm (go-gopkg-in-check-v1)[arguments]: Don't run
the test suite when building with gccgo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 98338cb701..ed31d330de 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4051,7 +4051,16 @@ which satisfies the cron expression.")
          "1jwxndf8rsyx0fgrp47d99rp55yzssmryb92jfj3yf7zd8rjjljn"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "gopkg.in/check.v1"))
+     (list
+       #:import-path "gopkg.in/check.v1"
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key inputs #:allow-other-keys #:rest args)
+               (unless
+                 ;; The tests fail when run with gccgo.
+                 (false-if-exception (search-input-file inputs "/bin/gccgo"))
+                 (apply (assoc-ref %standard-phases 'check) args)))))))
     (propagated-inputs
      (list go-github-com-kr-pretty))
     (home-page "https://gopkg.in/check.v1")