summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-11-27 20:48:10 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-11-30 15:50:16 +0100
commit24b199fd1882de6444baa44cc379bf7e1c228488 (patch)
tree3366d9af6cfbb0a07ca993fed8773ba81af7c36f /gnu
parenta36074a8290137c827abd8d49129c89c647570d9 (diff)
downloadguix-24b199fd1882de6444baa44cc379bf7e1c228488.tar.gz
gnu: ocaml-bitstring: Remove unneeded dependencies.
* gnu/packages/ocaml.scm (ocaml-bitstring): Remove unneeded dependencies
[native-inputs]: Remove camlp4 and bisect.
[propagated-inputs]: Remove camlp4.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6bb477d268..e517326e95 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1408,14 +1408,11 @@ ocaml-migrate-parsetree")
                 "15jjk2pq1vx311gl49s5ag6x5y0654x35w75z07g7kr2q334hqps"))))
     (build-system dune-build-system)
     (native-inputs
-     `(("camlp4" ,camlp4)
-       ("time" ,time)
+     `(("time" ,time)
        ("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("bisect" ,ocaml-bisect)))
+       ("automake" ,automake)))
     (propagated-inputs
-     `(("camlp4" ,camlp4)
-       ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)))
+     `(("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)))
     (arguments
      `(#:tests? #f; Tests fail to build
        #:jbuild? #t))