summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-09-24 19:18:58 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-24 19:18:58 +0200
commit24f7bac02a70257a7cd1bb2e1ec35d7cc753057e (patch)
tree6bd5c2907f441ba995c354367cd1746202493d04 /gnu
parentb150e83bef766ca67a3931afce36b6cb6c7f8c10 (diff)
downloadguix-24f7bac02a70257a7cd1bb2e1ec35d7cc753057e.tar.gz
gnu: openscenegraph: Update to 3.6.4 and build JPEG plugin.
* gnu/packages/graphics.scm (openscenegraph): Update to 3.6.4.
[inputs]: Add libjpeg.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index cd33ea2800..d4e9adb84a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -15,6 +15,7 @@
 ;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
 ;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
 ;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -510,7 +511,7 @@ visual effects work for film.")
 (define-public openscenegraph
   (package
     (name "openscenegraph")
-    (version "3.6.3")
+    (version "3.6.4")
     (source
      (origin
        (method git-fetch)
@@ -519,7 +520,7 @@ visual effects work for film.")
              (commit (string-append "OpenSceneGraph-" version))))
        (sha256
         (base32
-         "0h32z15sa8sbq276j0iib0n707m8bs4p5ji9z2ah411446paad9q"))
+         "0x8hdbzw0b71j91fzp9cwmy9a7ava8v8wwyj8nxijq942vdx1785"))
        (file-name (git-file-name name version))))
     (properties
      `((upstream-name . "OpenSceneGraph")))
@@ -538,6 +539,7 @@ visual effects work for film.")
        ("unzip" ,unzip)))
     (inputs
      `(("giflib" ,giflib)
+       ("libjpeg" ,libjpeg)             ; Required for the JPEG texture plugin.
        ("jasper" ,jasper)
        ("librsvg" ,librsvg)
        ("libxrandr" ,libxrandr)