summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 21:33:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:19:45 +0300
commit257023978aca29d381d63d00e4a6cc1d1bd2857a (patch)
tree413d6ba4586f244c7ea24730eb5b8575c9041bb3 /gnu
parentddc63a561193bcbda04bcc70f9c2c992bdb9e577 (diff)
downloadguix-257023978aca29d381d63d00e4a6cc1d1bd2857a.tar.gz
gnu: Add python-consul.
* gnu/packages/python.scm (python-consul): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 648b8bec0b..edc99dc0d4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10213,6 +10213,36 @@ interface for programs.")
        `(("python2-setuptools" ,python2-setuptools)
          ,@(package-native-inputs base))))))
 
+(define-public python-consul
+  (package
+    (name "python-consul")
+    (version "0.6.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "python-consul" version))
+        (sha256
+         (base32
+          "0rfyxcy4cr3x848vhx876ifalxd5ghq6l5x813m49h4vq2d4jiq8"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/cablehead/python-consul")
+    (synopsis "Python client for Consul")
+    (description
+     "Python client for @url{http://www.consul.io/,Consul}, a tool for service
+discovery, monitoring and configuration.")
+    (license license:expat)))
+
+(define-public python2-consul
+  (let ((consul (package-with-python2 python-consul)))
+    (package (inherit consul)
+      (native-inputs
+       `(("python2-setuptools" ,python2-setuptools)
+         ,@(package-native-inputs consul))))))
+
 (define-public python-schematics
   (package
     (name "python-schematics")