summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-08 12:49:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-09 14:30:38 +0200
commit2604ecb3a9fc00c98359ecb6059eacfa6573e515 (patch)
tree64538a96643a6bc7e81600a99bcc07cd874860eb /gnu
parent0ab7f6c5f4646ca52d6aa54e0adbb4f8b45f9263 (diff)
downloadguix-2604ecb3a9fc00c98359ecb6059eacfa6573e515.tar.gz
gnu: smithwaterman: Update to 0.0.0-2.2610e25.
* gnu/packages/bioinformatics.scm (smithwaterman): Update to 0.0.0-2.2610e25.
[arguments]: Add make-flags to build static library. Adjust custom
'install phase to install static library.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bde4aad785..0e4cb5b1db 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14942,11 +14942,10 @@ some of the details of opening and jumping in tabix-indexed files.")
    (license license:expat)))
 
 (define-public smithwaterman
-  ;; TODO: Upgrading smithwaterman breaks FreeBayes.
-  (let ((commit "203218b47d45ac56ef234716f1bd4c741b289be1"))
+  (let ((commit "2610e259611ae4cde8f03c72499d28f03f6d38a7"))
     (package
       (name "smithwaterman")
-      (version (string-append "0-1." (string-take commit 7)))
+      (version (git-version "0.0.0" "2" commit))
       (source (origin
         (method git-fetch)
         (uri (git-reference
@@ -14954,17 +14953,21 @@ some of the details of opening and jumping in tabix-indexed files.")
               (commit commit)))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "0z9xsmsv452kgdfbbwydyc6nymg3fwyv8zswls8qjin3r4ia4415"))))
+         (base32 "0i9d8zrxpiracw3mxzd9siybpy62p06rqz9mc2w93arajgbk45bs"))))
       (build-system gnu-build-system)
       (arguments
        `(#:tests? #f ; There are no tests to run.
+         #:make-flags '("libsw.a" "all")
          #:phases
          (modify-phases %standard-phases
            (delete 'configure) ; There is no configure phase.
            (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
-               (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-                 (install-file "smithwaterman" bin))
+               (let* ((out (assoc-ref outputs "out"))
+                      (bin (string-append out "/bin"))
+                      (lib (string-append out "/lib")))
+                 (install-file "smithwaterman" bin)
+                 (install-file "libsw.a" lib))
                #t)))))
       (home-page "https://github.com/ekg/smithwaterman")
       (synopsis "Implementation of the Smith-Waterman algorithm")