summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-01 16:04:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-01 16:05:25 +0200
commit26117c6046a3f1e46a256df82d9246fd5fb782a5 (patch)
tree00a9c3096e14a91a60fd35f04a8bebb5543e0fd9 /gnu
parent7e2e14b866e31c9416c085e6190f4905e94b6f00 (diff)
downloadguix-26117c6046a3f1e46a256df82d9246fd5fb782a5.tar.gz
gnu: Add r-mcmcpack.
* gnu/packages/cran.scm (r-mcmcpack): New variable.

Co-authored-by: Marcel Schilling <marcel.schilling@uni-luebeck.de>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 11864bd13c..b31a88fc3c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17933,6 +17933,38 @@ than available RAM.  All core functions are parallelized to benefit from
 multicore machines.")
     (license license:gpl2+)))
 
+(define-public r-mcmcpack
+  (package
+    (name "r-mcmcpack")
+    (version "1.5-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "MCMCpack" version))
+       (sha256
+        (base32
+         "1khavqsimiwbfq7gyw5jyj67jxfd579pnc7mngnd655zc8yzspvr"))))
+    (properties `((upstream-name . "MCMCpack")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-coda" ,r-coda)
+       ("r-lattice" ,r-lattice)
+       ("r-mass" ,r-mass)
+       ("r-mcmc" ,r-mcmc)
+       ("r-quantreg" ,r-quantreg)))
+    (home-page "https://cran.r-project.org/package=MCMCpack")
+    (synopsis "Markov Chain Monte Carlo (MCMC) package")
+    (description
+     "This package contains functions to perform Bayesian inference using
+posterior simulation for a number of statistical models.  Most simulation is
+done in compiled C++ written in the Scythe Statistical Library.  All models
+return @code{coda} @code{mcmc} objects that can then be summarized using the
+@code{coda} package.  Some useful utility functions such as density functions,
+pseudo-random number generators for statistical distributions, a general
+purpose Metropolis sampling algorithm, and tools for visualization are
+provided.")
+    (license license:gpl3)))
+
 (define-public r-xmlparsedata
   (package
     (name "r-xmlparsedata")