summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-06-25 09:04:17 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-25 15:12:05 +0200
commit285f9d5e95993e6950242064418ff8d36ed83f02 (patch)
treedfd01fcd4c5f2cab6b1def4be4e325c967bed16b /gnu
parent88c7c739740b56cab132cf1a3f16392c434408f7 (diff)
downloadguix-285f9d5e95993e6950242064418ff8d36ed83f02.tar.gz
gnu: suitesparse: Link against OpenBLAS rather than LAPACK.
* gnu/packages/maths.scm (suitesparse)[inputs]: Replace LAPACK with
OPENBLAS.
[arguments]: Add "BLAS"and "LAPACK" to #:make-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 766c29271a..954f4604c1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4098,6 +4098,11 @@ Fresnel integrals, and similar related functions as well.")
        (list (string-append "CC=" ,(cc-for-target))
              "TBB=-ltbb"
              "MY_METIS_LIB=-lmetis"
+
+             ;; The default is to link against netlib lapack.  Use OpenBLAS
+             ;; instead.
+             "BLAS=-lopenblas" "LAPACK=-lopenblas"
+
              ;; Flags for cmake (required to build GraphBLAS and Mongoose)
              (string-append "CMAKE_OPTIONS=-DCMAKE_INSTALL_PREFIX="
                             (assoc-ref %outputs "out")
@@ -4117,7 +4122,7 @@ Fresnel integrals, and similar related functions as well.")
          (delete 'configure))))         ;no configure script
     (inputs
      `(("tbb" ,tbb)
-       ("lapack" ,lapack)
+       ("openblas" ,openblas)
        ("gmp" ,gmp)
        ("mpfr" ,mpfr)
        ("metis" ,metis)))