summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-22 18:24:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-22 18:48:23 +0100
commit28b0b21e3f406cdf3ba9ff32ce80c7108d3d032e (patch)
treef82789d009fdbbd091836470801dfae58da237bd /gnu
parent1a35f274af16278be769eb72cddea1b14701ab26 (diff)
downloadguix-28b0b21e3f406cdf3ba9ff32ce80c7108d3d032e.tar.gz
gnu: parallel: Don't end phase with #<undefined>.
* gnu/packages/parallel.scm (parallel)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/parallel.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index d44a422ec2..337e9d4cb3 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -76,10 +76,10 @@
              #t))
          (add-after 'install 'post-install-test
            (lambda* (#:key outputs #:allow-other-keys)
-             (zero? (system* (string-append
-                              (assoc-ref outputs "out") "/bin/parallel")
-                             "echo"
-                             ":::" "1" "2" "3")))))))
+             (invoke (string-append
+                      (assoc-ref outputs "out") "/bin/parallel")
+                     "echo"
+                     ":::" "1" "2" "3"))))))
     (inputs
      `(("perl" ,perl)
        ("procps" ,procps)))