summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-15 00:10:44 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:27 +0100
commit29157edcd669e6cb500deee9e41a655a0da17618 (patch)
tree130969ffbddd8384a48ff8c799ccde4992084c07 /gnu
parentad80c7ef158648ebbde10d1ddaff96ac94d4d7c9 (diff)
downloadguix-29157edcd669e6cb500deee9e41a655a0da17618.tar.gz
gnu: Add ksmtp.
* gnu/packages/kde-pim.scm (ksmtp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-pim.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index ce89dba1b6..2ced957708 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -561,6 +561,46 @@ easier to do so.")
     (license ;; GPL for programs, LGPL for libraries, FDL for documentation
      (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
 
+(define-public ksmtp
+  (package
+    (name "ksmtp")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/ksmtp-" version ".tar.xz"))
+       (sha256
+        (base32 "1pd8mma3xbq83jkn76gqinn6xh9imaji0jrg3qzysf5rvjl8kcqn"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("cyrus-sasl" ,cyrus-sasl)
+       ("kcodecs" ,kcodecs)
+       ("kconfig" ,kconfig)
+       ("kcoreaddons" ,kcoreaddons)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:tests? #f ;; TODO: does not find sasl mechs
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'Use-KDE_INSTALL_TARGETS_DEFAULT_ARGS-when-installing
+           (lambda _
+             (substitute* "src/CMakeLists.txt"
+               (("^(install\\(.* )\\$\\{KF5_INSTALL_TARGETS_DEFAULT_ARGS\\}\\)"
+                 _ prefix)
+                (string-append prefix "${KDE_INSTALL_TARGETS_DEFAULT_ARGS})")))
+             #t)))))
+    (home-page "https://cgit.kde.org/ksmtp.git")
+    (synopsis "Library for sending email through an SMTP server")
+    (description "This library provides an API for handling SMTP
+services.  SMTP (Simple Mail Transfer Protocol) is the most prevalent Internet
+standard protocols for e-mail transmission.")
+    (license license:lgpl2.0+)))
+
 (define-public ktnef
   (package
     (name "ktnef")