summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2016-11-15 22:53:21 +0200
committerLeo Famulari <leo@famulari.name>2016-11-25 00:38:10 -0500
commit2cd3b6fd03b987eb55b2ab9fd3817696d4f1a4d5 (patch)
tree02f2ef0c629278f02d5281612716caae50b3683a /gnu
parent88d45b74c17377e0bf27c823f87ef3e642bcc451 (diff)
downloadguix-2cd3b6fd03b987eb55b2ab9fd3817696d4f1a4d5.tar.gz
gnu: Add wxwidgets-gtk2.
* gnu/packages/wxwidgets.scm (wxwidgets-gtk2): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wxwidgets.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 31da2a9eed..4efe7a13bc 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -109,3 +110,11 @@ and many other languages.")
                             (assoc-ref %outputs "out") "/lib"))
        ;; No 'check' target.
        #:tests? #f))))
+
+(define-public wxwidgets-gtk2
+  (package (inherit wxwidgets)
+           (inputs `(("gtk+" ,gtk+-2)
+                     ,@(alist-delete
+                        "gtk+"
+                        (package-inputs wxwidgets))))
+           (name "wxwidgets-gtk2")))