summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-07-14 12:47:06 +0100
committerMark H Weaver <mhw@netris.org>2019-07-14 15:04:41 -0400
commit2f3c0fb39d8bc6fc9a629b79947691da48ca42e9 (patch)
tree7a8fa4395323b25e3a47a318c01c9c0f8ac4e2d2 /gnu
parentbe7eebe26dbbea10bf40e4cf54250c79ed581952 (diff)
downloadguix-2f3c0fb39d8bc6fc9a629b79947691da48ca42e9.tar.gz
gnu: linux-libre: Fix build on aarch64.
* gnu/packages/linux.scm (make-linux-libre)[arguments]: Remove
'work-around-gcc-7-include-path-issue phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2b22c344ea..4c31f7d750 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -35,6 +35,7 @@
 ;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Stefan Stefanović <stefanx2ovic@gmail.com>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -355,11 +356,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
              (substitute* (find-files "." "^Makefile(\\.include)?$")
                (("/bin/pwd") "pwd"))
              #t))
-         (add-before 'configure 'work-around-gcc-7-include-path-issue
-           (lambda _
-             (unsetenv "C_INCLUDE_PATH")
-             (unsetenv "CPLUS_INCLUDE_PATH")
-             #t))
          (replace 'configure
            (lambda* (#:key inputs native-inputs target #:allow-other-keys)
              ;; Avoid introducing timestamps