summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-04-01 18:38:58 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-01 18:41:28 +0200
commit301a4249064227bc4883e4e5b638e85a65925ba0 (patch)
tree49307a588a7c8ff930e312c8867e0dd4efb8e9cf /gnu
parentd32922759bfeffa03ee189158ea00b1a0ddbe8c6 (diff)
downloadguix-301a4249064227bc4883e4e5b638e85a65925ba0.tar.gz
gnu: sed: Update to 4.5.
* gnu/packages/base.scm (sed): Update to 4.5.
[arguments]: Remove 'patch-test-suite' phase.
[native-inputs]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm14
-rw-r--r--gnu/packages/commencement.scm10
2 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a65e932df4..88eaee767f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -128,14 +128,14 @@ including, for example, recursive directory searching.")
 (define-public sed
   (package
    (name "sed")
-   (version "4.4")
+   (version "4.5")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/sed/sed-" version
                                 ".tar.xz"))
             (sha256
              (base32
-              "0fv88bcnraixc8jvpacvxshi30p5x9m7yb8ns1hfv07hmb2ypmnb"))))
+              "0h3b2jfj57wmz680vkbyavlsrkak556qhvs7m7fdlawwhg477bbs"))))
    (build-system gnu-build-system)
    (synopsis "Stream editor")
    (arguments
@@ -149,15 +149,9 @@ including, for example, recursive directory searching.")
             (substitute* "Makefile.in"
               (("^doc/sed\\.1:.*")
                "doc/sed.1:\n"))
-            #t))
-        (add-before 'patch-source-shebangs 'patch-test-suite
-          (lambda* (#:key inputs #:allow-other-keys)
-            (patch-makefile-SHELL "testsuite/Makefile.tests")
-            (substitute* '("testsuite/bsd.sh"
-                           "testsuite/bug-regex9.c")
-              (("/bin/sh")
-               (which "sh")))
             #t)))))
+   (native-inputs
+    `(("perl" ,perl)))                            ;for tests
    (description
     "Sed is a non-interactive, text stream editor.  It receives a text
 input from a file or from standard input and it then applies a series of text
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index bcb7cf3093..88297d33e8 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -928,6 +928,14 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
     ("grep" ,grep-final)
     ,@%boot5-inputs))
 
+(define sed-final
+  ;; The final sed.
+  (let ((sed (package-with-bootstrap-guile
+              (package-with-explicit-inputs sed %boot6-inputs
+                                            (current-source-location)
+                                            #:guile guile-final))))
+    (package/inherit sed (native-inputs `(("perl" ,perl-boot0))))))
+
 (define-public %final-inputs
   ;; Final derivations used as implicit inputs by 'gnu-build-system'.  We
   ;; still use 'package-with-bootstrap-guile' so that the bootstrap tools are
@@ -946,9 +954,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
                ("file" ,file)
                ("diffutils" ,diffutils)
                ("patch" ,patch)
-               ("sed" ,sed)
                ("findutils" ,findutils)
                ("gawk" ,gawk)))
+      ("sed" ,sed-final)
       ("grep" ,grep-final)
       ("coreutils" ,coreutils-final)
       ("make" ,gnu-make-final)