summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-12 16:18:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-12 17:39:57 +0300
commit321bb9f0e90140da6a7b064ce3892b261a494ece (patch)
treea97b869f3b556b6f399d685fea5186057f9e5767 /gnu
parentd1a235d72ddfbcef5c27076eebbaa7009fee0182 (diff)
downloadguix-321bb9f0e90140da6a7b064ce3892b261a494ece.tar.gz
gnu: libratbag: Only build with valgrind on supported systems.
* gnu/packages/gnome.scm (libratbag)[arguments]: Disable some tests when
valgrind isn't present.
[native-inputs]: Only add valgrind on systems which support it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f8665c215c..27eb065043 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2018 Rene Saavedra <pacoon@protonmail.com>
 ;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
 ;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
@@ -11937,7 +11937,10 @@ It uses pandoc as back-end for parsing Markdown.")
     (arguments
      `(#:configure-flags
        (list "-Dsystemd=false"
-             "-Dlogind-provider=elogind")
+             "-Dlogind-provider=elogind"
+             ,@(if (not (package? (this-package-native-input "valgrind")))
+                 `("-Dtests=false")     ; Some tests still run.
+                 `()))
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap
@@ -11957,7 +11960,11 @@ It uses pandoc as back-end for parsing Markdown.")
                  python-wrap)
                #t))))))
     (native-inputs
-     (list check pkg-config swig valgrind))
+     (append
+       (list check pkg-config swig)
+       (if (member (%current-system) (package-supported-systems valgrind))
+         (list valgrind)
+         '())))
     (inputs
      `(("glib" ,glib)
        ("json-glib" ,json-glib)