summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 16:28:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commit38306e11685b18e9fff5766252b39942da0d75d9 (patch)
tree8bdc19938b04116d4b17f27808e4f721b84ad36a /gnu
parent91dd8b368703ab0d183839fbe9fa8a3d23bf5001 (diff)
downloadguix-38306e11685b18e9fff5766252b39942da0d75d9.tar.gz
gnu: Add python-qtconsole.
* gnu/packages/python.scm (python-qtconsole): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f68062a481..8bc2935761 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7333,6 +7333,42 @@ Jupyter kernels such as IJulia and IRKernel.")
       "python-ipython"
       (package-propagated-inputs python-jupyter-console)))))
 
+(define-public python-qtconsole
+  (package
+    (name "python-qtconsole")
+    (version "4.4.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "qtconsole" version))
+       (sha256
+        (base32
+         "1b03n1ixzscm0jw97l4dq5iy4fslnqxq5bb8287xb7n2a1gs26xw"))))
+    (build-system python-build-system)
+    (arguments
+     ;; XXX: Tests are disabled, because this package needs python-ipython 7,
+     ;; but we only have the LTS version 5.x.  This means that there might be
+     ;; runtime errors, but since this is a dependency of the Jupyter package,
+     ;; and Jupyter can be used without the qtconsole we can overlook this for
+     ;; now.
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           (lambda _
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (propagated-inputs
+     `(("python-ipykernel" ,python-ipykernel)
+       ("python-ipython" ,python-ipython)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "http://jupyter.org")
+    (synopsis "Jupyter Qt console")
+    (description "This package provides a Qt-based console for Jupyter with
+support for rich media output.")
+    (license license:bsd-3)))
+
 (define-public jupyter
   (package
     (name "jupyter")