summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-15 12:29:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-15 12:30:26 +0200
commit3ad3869297fd327ef417b1ecb95c2c4caf53d2e6 (patch)
tree23a692e12ba88208548f227a7800360c1ba0cab1 /gnu
parentf4dc53881b79b324ce7da731ac579a41c5078a48 (diff)
downloadguix-3ad3869297fd327ef417b1ecb95c2c4caf53d2e6.tar.gz
gnu: rkdeveloptool: Fix build failure.
This change was tested against a Pinebook Pro.

* gnu/packages/hardware.scm (rkdeveloptool)[source]: Add snippet to fix
build errors based on upstream pull request.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/hardware.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 65558ffe08..1b8ba9bc43 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2022 Marcel Kupiec <formbi@protonmail.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1132,7 +1133,14 @@ supported by the Linux kernel.")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0zwrkqfxd671iy69v3q0844gfdpm1yk51i9qh2rqc969bd8glxga"))))
+          (base32 "0zwrkqfxd671iy69v3q0844gfdpm1yk51i9qh2rqc969bd8glxga"))
+         (snippet
+          #~(begin
+              ;; https://github.com/rockchip-linux/rkdeveloptool/pull/57
+              (use-modules (guix build utils))
+              (substitute* "main.cpp"
+                (("snprintf\\(buffer, sizeof\\(buffer\\), \"\\%s\", chip)")
+                 "memccpy(buffer, chip, '\\0', sizeof(buffer))"))))))
       (build-system gnu-build-system)
       (native-inputs
        (list autoconf automake pkg-config))