summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 22:50:12 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:33 -0500
commit3d91c07875c63fa0976bb863d463e7da436c1b07 (patch)
treec1ef577fde4ff606fc763a7e16aed98c65664673 /gnu
parent2257e650791ed5678204451e2221ac36f6c4b119 (diff)
downloadguix-3d91c07875c63fa0976bb863d463e7da436c1b07.tar.gz
gnu: pciutils: Fix the conditional for the kmod input.
Fixes <https://issues.guix.gnu.org/52411>.  Thanks to Maxime Devos for
suggesting the solution.

* gnu/packages/pciutils.scm (pciutils): Delete trailing #t.

[inputs]{kmod}: Use the hurd-target? procedure in the condition, which
correctly handles the Nix system of %current-system and GNU triplet of
%current-target-system.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pciutils.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/pciutils.scm b/gnu/packages/pciutils.scm
index 47275a8ff0..b6b1e3ad85 100644
--- a/gnu/packages/pciutils.scm
+++ b/gnu/packages/pciutils.scm
@@ -87,8 +87,7 @@
 
                (("^IDSDIR=.*$")
                 ;; Installation directory of 'pci.ids.gz'.
-                "IDSDIR = $(SHAREDIR)/hwdata\n"))
-             #t))
+                "IDSDIR = $(SHAREDIR)/hwdata\n"))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Install the commands, library, and .pc files.
@@ -111,9 +110,7 @@
     (native-inputs
      (list which pkg-config))
     (inputs
-     `(,@(if (member (or (%current-target-system)
-                         (%current-system))
-                     (package-supported-systems kmod))
+     `(,@(if (not (hurd-target?))
              `(("kmod" ,kmod))
              '())
        ,@(if (hurd-target?)