summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-31 18:16:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-31 18:16:05 +0200
commit3e902bbb56e34669bc3de8a3768104aa118a0881 (patch)
tree90c2320e673cc94464da5036f52ba2d58b22e38a /gnu
parent95ac5cd66854566feeb87174edadf60fccd44c31 (diff)
downloadguix-3e902bbb56e34669bc3de8a3768104aa118a0881.tar.gz
gnu: util-linux: Skip setarch tests when building on armhf-linux.
* gnu/packages/linux.scm (util-linux)[arguments]: When building on
armhf-linux, disable the setarch tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b56803066b..faedce7250 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1216,6 +1216,21 @@ providing the system administrator with some help in common tasks.")
                         (substitute* "tests/ts/column/invalid-multibyte"
                           (("C\\.UTF-8") "en_US.utf8"))
                         #t)))
+                  ;; TODO: Remove the conditional on the next rebuild cycle.
+                  ,@(if (string-prefix? "arm" (%current-system))
+                        '((add-before 'check 'disable-setarch-test
+                            (lambda _
+                              ;; The setarch tests are unreliable in QEMU's
+                              ;; user-mode emulation, which is our primary
+                              ;; method of building ARMv7 packages.
+                              ;; <https://github.com/karelzak/util-linux/issues/601>
+                              (substitute* "tests/ts/misc/setarch"
+                                (("ts_init_subtest.*" all)
+                                 (string-append
+                                  all "\n"
+                                  "ts_skip \"setarch tests are unreliable under QEMU\"")))
+                              #t)))
+                        '())
                   (add-after 'install 'move-static-libraries
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let ((lib    (assoc-ref outputs "lib"))