summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-02-10 16:39:09 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-10 21:30:32 +0100
commit3fc88ff0f3499b9be2eb8177084752feb2e2508f (patch)
tree1ec789677cd3e1e22359bc6fa1b10a4410c27ac0 /gnu
parent8c16b8a40ca3a77ee819b05d825b30671f1d536c (diff)
downloadguix-3fc88ff0f3499b9be2eb8177084752feb2e2508f.tar.gz
gnu: Add ghc-alsa-core.
* gnu/packages/haskell.scm (ghc-alsa-core): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 255e902e66..eecb5b71c4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11493,4 +11493,29 @@ imported with the correct Haskell types.")
 Music Player Daemon.")
     (license license:expat)))
 
+(define-public ghc-alsa-core
+  (package
+    (name "ghc-alsa-core")
+    (version "0.5.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://hackage/package/alsa-core/alsa-core-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1avh4a419h9d2zsslg6j8hm87ppgsgqafz8ll037rk2yy1g4jl7b"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+       ("alsa-lib" ,alsa-lib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.haskell.org/haskellwiki/ALSA")
+    (synopsis "Binding to the ALSA Library API (Exceptions)")
+    (description "This package provides access to ALSA infrastructure, that is
+needed by both alsa-seq and alsa-pcm.")
+    (license license:bsd-3)))
 ;;; haskell.scm ends here