summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-02-04 22:00:01 -0500
committerLudovic Courtès <ludo@gnu.org>2018-02-05 16:54:27 +0100
commit439ad15ddd532a369f44db7e86e602d33890581d (patch)
treeae2852c950d0e9251b6f4d7b3e0a48f2f65ae3a4 /gnu
parent7c599eac0c26ea0cc61d711c5e777b893519e90c (diff)
downloadguix-439ad15ddd532a369f44db7e86e602d33890581d.tar.gz
gnu: Add emacs-test-simple.
* gnu/packages/emacs.scm (emacs-test-simple): New public variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 83c4ae340c..f29e28983a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3165,6 +3165,27 @@ perspective only its buffers are available by default.")
     ;; the Expat license.
     (license license:gpl3+)))
 
+(define-public emacs-test-simple
+  (package
+    (name "emacs-test-simple")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/test-simple-"
+                           version ".el"))
+       (sha256
+        (base32
+         "1yd61jc9ds95a5n09052kwc5gasy57g4lxr0jsff040brlyi9czz"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/rocky/emacs-test-simple")
+    (synopsis "Simple unit test framework for Emacs Lisp")
+    (description
+     "Test Simple is a simple unit test framework for Emacs Lisp.  It
+alleviates the need for context macros, enclosing specifications or required
+test tags.  It supports both interactive and non-interactive use.")
+    (license license:gpl3+)))
+
 (define-public emacs-request
   (package
     (name "emacs-request")