summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:52 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:36 +0200
commit46472ae54546853b3bde1c4e7ed74ec641ca0476 (patch)
tree45af83857fc3c4d447a1b5a66a512b430ffe9deb /gnu
parent4486b111d371a5b9d2ea7857a68ce19aaece2257 (diff)
downloadguix-46472ae54546853b3bde1c4e7ed74ec641ca0476.tar.gz
gnu: Add julia-biosymbols.
* gnu/packages/julia-xyz.scm (julia-biosymbols): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c63bc77a87..f747c72a42 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -387,6 +387,37 @@ many of the other BioJulia packages.  This package defines IO, exceptions, and
 other types or methods used by other BioJulia packages.")
       (license license:expat))))
 
+(define-public julia-biosymbols
+  (package
+    (name "julia-biosymbols")
+    ;; Older release for compatibility with julia-biosequences.
+    (version "4.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/BioJulia/BioSymbols.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1222rwdndi777lai8a6dwrh35i5rgmj75kcrhn8si72sxgz0syjm"))))
+    (build-system julia-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'adjust-tests
+           (lambda _
+             (substitute* "test/runtests.jl"
+               (("\\@testset \\\"Range.*" all)
+                (string-append all " return\n"))))))))
+    (propagated-inputs
+     (list julia-automa))
+    (home-page "https://github.com/BioJulia/BioSymbols.jl")
+    (synopsis "Primitive types for nucleic acids and amino acids")
+    (description "This package defines the primitive types for nucleic acids
+and amino acids that are used ny otherBioJulia packages.")
+    (license license:expat)))
+
 (define-public julia-blockarrays
   (package
     (name "julia-blockarrays")