summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-31 15:42:02 -0400
committerDavid Thompson <davet@gnu.org>2016-06-03 08:54:25 -0400
commit4aea1e016035671d2be1f13f94849a9f5fd2c4d8 (patch)
tree8af4a25f3f268b7d53ce47f1c251cfa1cdaff528 /gnu
parenta2670dde107717a0f6298e9e6d125848cbdfbb57 (diff)
downloadguix-4aea1e016035671d2be1f13f94849a9f5fd2c4d8.tar.gz
gnu: Add emacs-elfeed.
* gnu/pacakges/emacs.scm (emacs-elfeed): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1b54439bc7..04dc7596c6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1887,3 +1887,23 @@ Currently git, mercurial and bazaar repos are considered projects by default.
 If you want to mark a folder manually as a project just create an empty
 .projectile file in it.")
     (license license:gpl3+)))
+
+(define-public emacs-elfeed
+  (package
+    (name "emacs-elfeed")
+    (version "1.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/skeeto/elfeed/archive/"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0i75r8x9ypbfjlnym04h16ikcrlks86p7wsgawrx7mh1lk4inp89"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/skeeto/elfeed")
+    (synopsis "Atom/RSS feed reader for Emacs")
+    (description
+     "Elfeed is an extensible web feed reader for Emacs, supporting both Atom
+and RSS, with a user interface inspired by notmuch.")
+    (license license:gpl3+)))