summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 22:36:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 22:37:13 +0100
commit4cb441955ebf9af30b2902a9fc76a68b44d1a4dc (patch)
tree9c8fcd0650ad976096cdae0f88fabe20bcbf9094 /gnu
parent3204411ff7185b4ea1c2e53fea92b6d05f273272 (diff)
downloadguix-4cb441955ebf9af30b2902a9fc76a68b44d1a4dc.tar.gz
gnu: Add r-wesanderson.
* gnu/packages/cran.scm (r-wesanderson): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e62c1c07f2..a66727c0a4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1725,6 +1725,26 @@ in R and Shiny via the D3 visualization library.")
       ;; 3-clause BSD license.
       (license (list license:gpl3+ license:bsd-3)))))
 
+(define-public r-wesanderson
+  (package
+    (name "r-wesanderson")
+    (version "0.3.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "wesanderson" version))
+       (sha256
+        (base32
+         "09mr6p2jmqdjq27cz974w5hyxgn929zp9z3inhxqmmh1582fmdi2"))))
+    (properties `((upstream-name . "wesanderson")))
+    (build-system r-build-system)
+    (home-page "https://github.com/karthik/wesanderson")
+    (synopsis "Wes Anderson color palette generator")
+    (description
+     "This package provides color palettes that have been generated mostly
+from Wes Anderson movies.")
+    (license license:expat)))
+
 (define-public r-crosstalk
   (package
     (name "r-crosstalk")