summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-02-19 12:54:06 +0100
committerRutger Helling <rhelling@mykolab.com>2018-02-19 12:56:47 +0100
commit4ecfc16839d103ba451cb88f9e51e2315d1564cc (patch)
tree60016bb34e2d44ce00b2d27577c0c556a94dd2c0 /gnu
parentd81a739a1f2db5b64c3e20f0cdb9862902624322 (diff)
downloadguix-4ecfc16839d103ba451cb88f9e51e2315d1564cc.tar.gz
gnu: xpra: Disable abstract X11 sockets.
* gnu/packages/xorg.scm (xpra): Disable abstract X11 sockets.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d0861ebee3..f5af15e1b8 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -12,7 +12,7 @@
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2016, 2017 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -6018,12 +6018,14 @@ basic eye-candy effects.")
              (substitute* "setup.py"
                (("/usr/lib/")
                 (string-append (assoc-ref outputs "out") "/lib/")))
+             ;; Use Xvfb with '-nolisten local' to disable abstract X11 sockets.
              (substitute* "./xpra/scripts/config.py"
                ((":.*join.*xvfb.*")
                 (string-append ": \"" (assoc-ref inputs "xorg-server")
                                "/bin/Xvfb +extension Composite"
                                " -screen 0 5760x2560x24+32 -dpi 96 -nolisten"
-                               " tcp -noreset -auth $XAUTHORITY\",\n")))
+                               " tcp -nolisten local -noreset -auth"
+                               " $XAUTHORITY\",\n")))
              (substitute* "./xpra/scripts/config.py"
                (("socket-dir.*: \"\",")
                 "socket-dir\"        : \"~/.xpra\","))