summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-08-29 09:16:30 -0400
committer宋文武 <iyzsong@member.fsf.org>2018-09-15 12:19:06 +0800
commit511f3be695bb4a3c83218e3fea273063da378051 (patch)
tree8f62abf498ba5733227b65391baa1d7ae87e06ea /gnu
parent2ee67781ff3246c32e4dcdfb3a9adc65967b33dd (diff)
downloadguix-511f3be695bb4a3c83218e3fea273063da378051.tar.gz
gnu: Add python-user-agents.
* gnu/packages/python.scm (python-user-agents, python2-user-agents): New
variables.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3c8b68ee1e..30b65f637b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5031,6 +5031,32 @@ toolkit.  Use it to build trees of widgets.")
 (define-public python2-ua-parser
   (package-with-python2 python-ua-parser))
 
+(define-public python-user-agents
+  (package
+    (name "python-user-agents")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "user-agents" version))
+       (sha256
+        (base32
+         "0fc00cd3j8dahq1zzn8pkgfgd7lq37bp2scmdma2n1c049vicgb4"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                  ;missing devices.json test file in release
+    (propagated-inputs
+     `(("python-ua-parser" ,python-ua-parser)))
+    (home-page "https://github.com/selwin/python-user-agents")
+    (synopsis "User Agent strings parsing library")
+  (description
+   "A library to identify devices (phones, tablets) and their capabilities by
+parsing (browser/HTTP) user agent strings.")
+  (license license:expat)))
+
+(define-public python2-user-agents
+  (package-with-python2 python-user-agents))
+
 (define-public python-dbus
   (package
     (name "python-dbus")