summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-21 16:24:05 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-22 15:23:23 +0200
commit5394a6a653e7338d73553eb77fa7c11c17562d3e (patch)
tree4284f264acc924267c7fbb44f788eaa5276ec516 /gnu
parent12c270ddd471a18a69ecfa016644c98734b3e601 (diff)
downloadguix-5394a6a653e7338d73553eb77fa7c11c17562d3e.tar.gz
gnu: Add python-redis.
* gnu/packages/python.scm (python-redis, python2-redis): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a3f5e1ccea..99c20ef07d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2170,6 +2170,33 @@ mining and data analysis.")
        `(("python2-pytz" ,python2-pytz)
          ,@(package-propagated-inputs scikit-image))))))
 
+(define-public python-redis
+  (package
+    (name "python-redis")
+    (version "2.10.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/r/redis/redis-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "1701qjwn4n05q90fdg4bsg96s27xf5s4hsb4gxhv3xk052q3gyx4"))))
+    (build-system python-build-system)
+    ;; Tests require a running Redis server
+    (arguments '(#:tests? #f))
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/andymccurdy/redis-py")
+    (synopsis "Redis Python client")
+    (description
+     "This package provides a Python interface to the Redis key-value store.")
+    (license license:expat)))
+
+(define-public python2-redis
+  (package-with-python2 python-redis))
+
 (define-public python-cython
   (package
     (name "python-cython")