summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-12 09:33:10 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-03 16:17:37 -0500
commit5588d9bd7a1f1982b6615fb050db65e16e354192 (patch)
tree79b40beff7294f5c47ed7a200791c3221fcbe986 /gnu
parent45ac52239a6f5c19e0ab324cff6c567a7e4e24d6 (diff)
downloadguix-5588d9bd7a1f1982b6615fb050db65e16e354192.tar.gz
gnu: %guile-static-3.0: New variable.
* gnu/packages/make-bootstrap.scm (%guile-static-3.0): New variable.
(%guile-static-stripped): Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 24855f6b28..a0999cb477 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -748,6 +748,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                                  "guile-default-utf8.patch"
                                  "guile-linux-syscalls.patch")))
 
+(define %guile-static-3.0
+  (make-guile-static guile-3.0-latest
+                     '("guile-2.2-default-utf8.patch"
+                       "guile-3.0-linux-syscalls.patch"
+                       "guile-3.0-relocatable.patch")))
+
 (define* (make-guile-static-stripped static-guile)
   (package
     (inherit static-guile)
@@ -796,11 +802,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
 (define %guile-static-stripped
   ;; A stripped static Guile 3.0 binary, for use in initrds
   ;; and during bootstrap.
-  (make-guile-static-stripped
-   (make-guile-static guile-3.0-latest
-                      '("guile-2.2-default-utf8.patch"
-                        "guile-3.0-linux-syscalls.patch"
-                        "guile-3.0-relocatable.patch"))))
+  (make-guile-static-stripped %guile-static-3.0))
 
 (define (tarball-package pkg)
   "Return a package containing a tarball of PKG."