summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-04 10:57:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-10 13:11:44 +0200
commit5a4aab219317c7423c48f26540719d86ff41c9c5 (patch)
tree3379f246d3c0bde6da6ff1914e5151515fa7b2ba /gnu
parentdb6982e4e2609bc63c5eea6e385e434a1478cafa (diff)
downloadguix-5a4aab219317c7423c48f26540719d86ff41c9c5.tar.gz
gnu: Add r-qtl2.
* gnu/packages/bioinformatics.scm (r-qtl2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 74a44874ee..bdb3ff761b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8239,6 +8239,35 @@ identify genotyping errors, and to perform single-QTL and two-QTL,
 two-dimensional genome scans.")
   (license license:gpl3)))
 
+(define-public r-qtl2
+  (package
+    (name "r-qtl2")
+    (version "0.20")
+    (source (origin
+      (method git-fetch)
+      ;; Not yet available in cran.
+      (uri (git-reference
+             (url "https://github.com/rqtl/qtl2.git")
+             (commit version)))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32 "0l1asr28q25jzbwrbg5490962sg3y4sjrd0qf09p78ws1aq8vfs0"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-data-table" ,r-data-table)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcppeigen" ,r-rcppeigen)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-yaml" ,r-yaml)))
+    (home-page "https://kbroman.org/qtl2/")
+    (synopsis
+     "QTL analysis software for high-dimensional data and complex cross designs")
+    (description
+     "R/qtl2 (aka qtl2) is a reimplementation of the QTL analysis software
+R/qtl, to better handle high-dimensional data and complex cross designs.")
+    (license license:gpl3)))
+
 (define-public r-zlibbioc
   (package
     (name "r-zlibbioc")