summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLukas Gradl <lgradl@openmailbox.org>2016-09-12 21:29:06 -0500
committerLudovic Courtès <ludo@gnu.org>2016-09-28 11:45:02 +0200
commit615c999055a3e830b5bea61b541e0cce857dd6c8 (patch)
tree481c2c7e52efae6f394e24ec3d0b77fad649fdfe /gnu
parent974aaf71e581cb82b5822e4ca3f76923af91caf5 (diff)
downloadguix-615c999055a3e830b5bea61b541e0cce857dd6c8.tar.gz
gnu: opendht: Propagate msgpack.
* gnu/packages/crypto.scm (opendht)[inputs]: Remove msgpack.
[propagated-inputs]: Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 40c9a74552..14084c91b1 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -147,9 +147,10 @@ OpenBSD tool of the same name.")
     (inputs
      `(("gnutls" ,gnutls)
        ("nettle" ,nettle)
-       ("msgpack" ,msgpack)
        ("readline" ,readline)
        ("argon2" ,argon2)))
+    (propagated-inputs
+     `(("msgpack" ,msgpack)))           ;included in several installed headers
     (native-inputs
      `(("autoconf" ,autoconf)
        ("pkg-config" ,pkg-config)