summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:47:16 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:28 -0600
commit625d0661fa9026d6eb69d156837001b841b92a1a (patch)
tree10fddacc3f0f2f7c924371bd5c9b9ee16af3cf76 /gnu
parent3a8ee9d163651c02f48b324c20e63292b02c1cef (diff)
downloadguix-625d0661fa9026d6eb69d156837001b841b92a1a.tar.gz
gnu: Add Module-Build.
* gnu/packages/perl.scm (perl-module-build): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index dd9d4836cb..6f6e8d5c92 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1773,6 +1773,31 @@ for use in reading and writing CPAN metadata files like META.yml and
 MYMETA.yml.")
     (license (package-license perl))))
 
+(define-public perl-module-build
+  (package
+    (name "perl-module-build")
+    (version "0.4211")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
+                           "Module-Build-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1c5hfhajr963w4mdjivsc7yz4vf4pz1rrfch5a93fbac1x2mr58h"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-cpan-meta" ,perl-cpan-meta)))
+    (home-page "http://search.cpan.org/dist/Module-Build")
+    (synopsis "Build and install Perl modules")
+    (description "\"Module::Build\" is a system for building, testing, and
+installing Perl modules.  It is meant to be an alternative to
+\"ExtUtils::MakeMaker\".  Developers may alter the behavior of the module
+through subclassing in a much more straightforward way than with
+\"MakeMaker\".  It also does not require a \"make\" on your system - most of
+the \"Module::Build\" code is pure-perl and written in a cross-platform way.")
+    (license (package-license perl))))
+
 (define-public perl-parse-cpan-meta
   (package
     (name "perl-parse-cpan-meta")