summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-27 13:24:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-27 13:37:29 +0200
commit63a5090869fac4f2b1c310d02b41d29669f3f389 (patch)
tree857ee3684f9ff3aa93a6022d50574d210c3b1493 /gnu
parent03f86ad65c99987fe8b31ee8939c95b9b5e78004 (diff)
downloadguix-63a5090869fac4f2b1c310d02b41d29669f3f389.tar.gz
gnu: Add r-emdist.
* gnu/packages/cran.scm (r-emdist): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8dd37434f2..4fb5b2d25b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -231,6 +231,26 @@ wrangling backend for the packages in the @code{easystats} ecosystem.")
 visualization of their differences.")
     (license license:gpl2+)))
 
+(define-public r-emdist
+  (package
+    (name "r-emdist")
+    (version "0.3-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "emdist" version))
+       (sha256
+        (base32
+         "1z14pb9z9nkd0f2c8pln4hzkfqa9dk9n3vg8czc8jiv0ndnqi7rq"))))
+    (properties `((upstream-name . "emdist")))
+    (build-system r-build-system)
+    (home-page "http://www.rforge.net/emd")
+    (synopsis "Earth mover's distance")
+    (description
+     "This package provides tools to calculate the Earth Mover's
+Distance (EMD).")
+    (license license:expat)))
+
 (define-public r-googledrive
   (package
     (name "r-googledrive")