summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 19:01:34 +0200
committerDavid Craven <david@craven.ch>2016-08-18 13:06:18 +0200
commit689bb11a346216e319f2cb66e5a9e9cc8c670655 (patch)
tree9009aaf1186f21cb94e223bae4ce580ed6f7d54c /gnu
parent0852f09a0d1c59bea655bd33281423f0539f7235 (diff)
downloadguix-689bb11a346216e319f2cb66e5a9e9cc8c670655.tar.gz
gnu: Add phonon.
* gnu/packages/kde-frameworks.scm (phonon): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index a679c64314..875d94aa1c 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -77,6 +77,34 @@ modules provided by CMake to find common software.  In addition, it provides
 common build settings used in software produced by the KDE community.")
     (license license:bsd-3)))
 
+(define-public phonon
+  (package
+    (name "phonon")
+    (version "4.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/phonon"
+                            "/" version "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "1q5hvsk4sfcb91625wcmldy7kgjmfpmpmkgzi6mxkqdd307v8x5v"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("qtbase" ,qtbase)))
+    (arguments
+     `(#:configure-flags
+       '("-DCMAKE_CXX_FLAGS=-fPIC"
+         "-DPHONON_BUILD_PHONON4QT5=ON")))
+    (home-page "https://phonon.kde.org")
+    (synopsis "KDE's multimedia library")
+    (description "KDE's multimedia library.")
+    (license license:lgpl2.1+)))
+
+
 ;; Tier 1
 ;;
 ;; Tier 1 frameworks depend only on Qt (and possibly a small number of other