summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-13 22:26:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-14 15:07:41 +0200
commit6949f45c105fe75d424420becf854030bf382378 (patch)
tree1738db35ee906bab2445f5195ab87653b8d227d4 /gnu
parentc5c42f0a9cb7207b196cfdab92751d41390dff0f (diff)
downloadguix-6949f45c105fe75d424420becf854030bf382378.tar.gz
gnu: opencv: Fix building on non-x86_64 systems.
* gnu/packages/image-processing.scm (opencv)[arguments]: Add
configure-flag to disable carotene. Don't require x86_64 CPU
except on x86_64. Fix typo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-processing.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9c2ec50bec..9be9ced927 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
 ;;; Copyright © 2018 Lprndn <guix@lprndn.info>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -235,6 +236,7 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
      `(#:configure-flags
        (list "-DWITH_IPP=OFF"
              "-DWITH_ITT=OFF"
+             "-DWITH_CAROTENE=OFF" ; only visible on arm/aarch64
 
              ;; CPU-Features:
              ;; See cmake/OpenCVCompilerOptimizations.cmake
@@ -245,10 +247,13 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
              "-DCPU_BASELINE=SSE2, NEON"
 
              "-DCPU_DISPATCH=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2"
-             "-DCPU_DISPATCH_REQUIRE=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2"
+             ,@(if (string-prefix? "x86_64" (or (%current-target-system)
+                                                (%current-system)))
+                   '("-DCPU_DISPATCH_REQUIRE=SSE3,SSSE3,SSE4_1,SSE4_2,AVX,AVX2")
+                   '())
 
              "-DBUILD_PERF_TESTS=OFF"
-             "-D BUILD_TESTS=ON"
+             "-DBUILD_TESTS=ON"
 
              (string-append "-DOPENCV_EXTRA_MODULES_PATH="
                             "/tmp/guix-build-opencv-" ,version ".drv-0"