summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-02-26 18:29:55 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2023-02-19 01:00:00 +0100
commit6bae14f61479f04a40fee44b1d1d89a33d9e93c0 (patch)
tree0c01225f7a42815c439a7199d62f84fe9eb932e4 /gnu
parenteb87d2c4a0b5d817e50a43d9f16d204650dc02e8 (diff)
downloadguix-6bae14f61479f04a40fee44b1d1d89a33d9e93c0.tar.gz
gnu: perl-encode: Update to 3.19 [fixes CVE-2021-36770].
* gnu/packages/perl.scm (perl-encode): Update to 3.19.
[propagated-inputs]: Remove.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7b97e7adfa..41b68baea8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4144,17 +4144,15 @@ the programmer to be mindfulof the space of platform variations.")
 (define-public perl-encode
   (package
     (name "perl-encode")
-    (version "3.10")
+    (version "3.19")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://cpan/authors/id/D/DA/DANKOGAI/"
                            "Encode-" version ".tar.gz"))
        (sha256
-        (base32 "1a8rwcrxxhq81jcdvdwns05c65jwr5r6bxvby6vdcr3ny5m91my2"))))
+        (base32 "1x9f0naqskv9v7dif480vrzfmn8zhvq9g0w3r164v7pnxr4ghqwi"))))
     (build-system perl-build-system)
-    (propagated-inputs
-     (list perl-exporter perl-storable perl-parent))
     (home-page "https://metacpan.org/dist/Encode")
     (synopsis "Character encodings in Perl")
     (description "Encode module provides the interface between Perl strings and