summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-03-17 12:50:26 +0300
committerJelle Licht <jlicht@fsfe.org>2021-03-22 22:02:00 +0100
commit6c1217c22c21e8c570ee9621ebec9d79b3b880f1 (patch)
treef234585d7261bc846ddc1c70037f3957c878cdc0 /gnu
parentb246420e40c80affddd21ba152d019af1f48297f (diff)
downloadguix-6c1217c22c21e8c570ee9621ebec9d79b3b880f1.tar.gz
gnu: Add emacs-ivy-hydra.
* gnu/packages/emacs-xyz.scm (emacs-ivy-hydra): New variable.

Signed-off-by: Jelle Licht <jlicht@fsfe.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 17ca645858..640cae5c35 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27275,3 +27275,27 @@ and prefered services can easily be configured.")
     (description
      "This package adds a \"C-'\" binding to Ivy minibuffer that uses Avy.")
     (license license:gpl3+)))
+
+(define-public emacs-ivy-hydra
+  (package
+    (name "emacs-ivy-hydra")
+    (version "0.13.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/"
+             "ivy-hydra-" version ".tar"))
+       (sha256
+        (base32 "06rln9bnq5hli5rqlm47fb68b8llpqrmzwqqv4rn7mx3854i9a5x"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-ivy" ,emacs-ivy)
+       ("emacs-hydra" ,emacs-hydra)))
+    (home-page "https://github.com/abo-abo/swiper")
+    (synopsis "Additional key bindings for Ivy")
+    (description
+     "This package provides the `hydra-ivy/body' command, which is a
+quasi-prefix map, with many useful bindings.  These bindings are
+shorter than usual, using mostly unprefixed keys.")
+    (license license:gpl3+)))