summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-10 00:19:53 +0200
committerMarius Bakke <marius@gnu.org>2022-08-10 00:28:59 +0200
commit6e2f570cded7b932692ece35a879c5d6db255825 (patch)
tree39436caf251a25a4ff3efca9d94cc3974f0b6ed3 /gnu
parent0b55b036c1cdd5409c638e4ab3efea1deea1b708 (diff)
downloadguix-6e2f570cded7b932692ece35a879c5d6db255825.tar.gz
gnu: cereal: List all licenses that apply.
* gnu/packages/serialization.scm (cereal)[license]: Add LICENSE:BOOST,
LICENSE:EXPAT, and LICENSE:NON-COPYLEFT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/serialization.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 1f2f7ff47f..79c55e2b2f 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -167,7 +167,17 @@ implement RPC protocols.")
      "Cereal is a header-only C++11 serialization library.  Cereal takes
 arbitrary data types and reversibly turns them into different representations,
 such as compact binary encodings, XML, or JSON.")
-    (license license:bsd-3)))
+    ;; Note: Cereal bundles forked versions of rapidxml and rapidjson
+    ;; (see include/cereal/external/), so list their licenses too.
+    (license (list license:bsd-3        ;Cereal itself
+                   ;; The bundled RapidXML is dual Boost/Expat (users choice).
+                   ;; RapidJSON is Expat licensed, and further bundles a
+                   ;; stdint.h with BSD-3.
+                   license:boost1.0 license:expat
+                   ;; Finally, include/cereal/external/base64.hpp has a
+                   ;; home-grown BSD-like license.
+                   (license:non-copyleft
+                    "file://include/cereal/external/LICENSE")))))
 
 ;; Some packages fail with the latest version.  Remove this variable
 ;; when unused.