summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-05-27 10:09:18 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-05-30 11:10:49 -0400
commit6ede256f77c32ba07ec43f1e7016103e5edcb626 (patch)
tree4ee3bb1263660c04a93f9dda627f47ccc4e5557c /gnu
parent02736daa8ca1be621b49b7ce282dfabf4919fa0a (diff)
downloadguix-6ede256f77c32ba07ec43f1e7016103e5edcb626.tar.gz
gnu: Add emacs-better-defaults.
* gnu/packages/emacs.scm (emacs-better-defaults): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index be397f133a..bfc4764541 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1775,3 +1775,24 @@ ongoing operations.")
 complement basic functions provided by @code{subr.el}.  All provided functions
 work on lists, strings and vectors.")
     (license license:gpl3+)))
+
+(define-public emacs-better-defaults
+  (package
+    (name "emacs-better-defaults")
+    (version "0.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/technomancy/better-defaults"
+                           "/archive/" version ".tar.gz"))
+       (sha256
+        (base32
+         "08fg4zslzlxbvyil5g4gwvwd22fh4zsgqprs5wh9hv1rgc6757m2"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/technomancy/better-defaults")
+    (synopsis "Better defaults for Emacs")
+    (description
+     "Better defaults attempts to address the most obvious deficiencies of the
+Emacs default configuration in uncontroversial ways that nearly everyone can
+agree upon.")
+    (license license:gpl3+)))